Browse Source

CI: bump nodejs to v10.x (LTS)

v8.x will be EOL at end of 2019.
nvm on Travis has outdated LTS aliases.
tags/untagged-0e014f77944d8517d79f
Jan Edmund Lazo 5 months ago
parent
commit
c065b0d75f
No known key found for this signature in database GPG Key ID: 64915E6E9F735B15
2 changed files with 3 additions and 3 deletions
  1. +1
    -1
      appveyor.yml
  2. +2
    -2
      ci/before_install.sh

+ 1
- 1
appveyor.yml View File

@@ -24,7 +24,7 @@ matrix:
fast_finish: true
install: []
before_build:
- ps: Install-Product node 8
- ps: Install-Product node 10
build_script:
- powershell ci\build.ps1
after_build:


+ 2
- 2
ci/before_install.sh View File

@@ -47,8 +47,8 @@ if [[ "${TRAVIS_OS_NAME}" == osx ]] || [ ! -f ~/.nvm/nvm.sh ]; then
fi

source ~/.nvm/nvm.sh
nvm install --lts
nvm use --lts
nvm install 10
nvm use 10

if [[ -n "$CMAKE_URL" ]]; then
echo "Installing custom CMake: $CMAKE_URL"


Loading…
Cancel
Save